Degraded Performance – Indeed Apply Integration for JazzHR

Incident Report for JazzHR

Postmortem

Incident Summary

Between August 26 and August 31, 2026, a technical issue affected the "Indeed Apply" feature for job postings. While job listings were still visible on Indeed, the streamlined application process was temporarily unavailable, and applicants were instead directed to complete their applications on employer career sites.

 Detection

The issue was identified on August 31, 2026, at 1:48 PM EDT following reports from customers and our integration partners. A review of system logs confirmed that the impact began on August 26, 2026. Because the job listings themselves continued to post successfully, standard automated alerts did not immediately signal the specific failure of the integrated application tool.

 Root Cause

The interruption was caused by a configuration issue during a routine security enhancement. This resulted in the job feed being sent without the required security token, which is necessary to validate and enable the "Indeed Apply" functionality.

 Resolution

Once the issue was reported, our engineering team identified the missing configuration within minutes. The following steps were taken to restore service on August 31, 2026:

  • Configuration Correction: The data packaging process was updated to ensure the security token is correctly included.
  • System Update: A corrected version of the service was deployed at 2:38 PM EDT.
  • Data Refresh: The job feed was fully regenerated and validated by 2:51 PM EDT.
  • Verification: Our team performed a manual audit of the updated feed at 2:55 PM EDT to confirm that all security credentials were functioning as expected.

 Preventative Measures

We are committed to maintaining a seamless experience for recruiters and candidates. To prevent this from happening again, we are implementing the following:

  • Enhanced Automated Testing: We have added new validation steps that specifically check for the presence of required application metadata before any job feed is published.
  • Process Audit: We have conducted a full review of our configuration management to ensure all service pathways are included in future security updates.
  • Improved Monitoring: We are developing more granular monitoring tools to alert our teams specifically if partner-integrated features become unavailable, even if general job posting remains active.
  • Updated Procedures: We have refined our internal deployment guides to ensure all necessary dependencies are verified during the update process.
Posted Sep 01, 2026 - 13:55 UTC

Resolved

We have verified the data feed to Indeed is now fully correct from our side and the feed has updated to reflect this. Jobs on Indeed that are not correctly showing the Indeed Apply option should be corrected during Indeed's next data ingest and processing event, which Indeed typically runs every 4 hours. We will continue to watch this area to insure no other issues arise.
Posted Aug 31, 2026 - 22:10 UTC

Monitoring

We have deployed a fix for the data being sent to Indeed and verified that our outbound data is now fully as Indeed expects it to be. We are monitoring this to insure no further changes are needed on our side and that the changes are seen by Indeed and actioned in job postings.

We apologize for the inconvenience and appreciate you being a JazzHR customer.
Posted Aug 31, 2026 - 18:58 UTC

Identified

We have determined that the Indeed Apply option was not showing as applied in all cases due to an error made during a recent update that affected how data was loaded into the feed provided to Indeed. We are working on a correction and will be deploying it as soon as practical.

We will provide further information here as it becomes available and when we have verified the fix is deployed.
Posted Aug 31, 2026 - 18:22 UTC

Investigating

We are currently investigating an issue affecting the Indeed Apply functionality for job listings published through JazzHR.

Customer Impact: Candidates applying to jobs on Indeed may not see the inline Indeed Apply option and will instead be redirected to complete their application on your company's career page. Career page applications are fully operational and unaffected.

Our engineering team is actively investigating, and we will provide an update as soon as more information is available.
Posted Aug 31, 2026 - 17:52 UTC
This incident affected: API.