JazzHR Service Degradation

Incident Report for JazzHR

Resolved

Update:
The issue remains resolved, and we have not observed any new issues. System performance and stability continue to operate within expected parameters.

Our teams will continue monitoring as a precaution, but no further customer impact has been identified.

Current Status: Resolved
Next Update: A Root Cause Analysis (RCA) will be provided within 7–10 business days.
Posted Jul 22, 2026 - 11:37 UTC

Monitoring

Fix Applied — Monitoring

A fix has been applied to resolve the reported issue. Our team is actively monitoring to confirm stability and ensure no recurrence. If you continue to experience any issues.
Posted Jul 21, 2026 - 23:20 UTC

Identified

Issue: Some JazzHR users are experiencing an application performance issue where the platform fails to fully load, with pages remaining in a loading state indefinitely.

Customer Impact: Affected users are unable to access the JazzHR platform, preventing them from managing candidates, requisitions, and other hiring workflows. No workaround is currently available.

Issue Identified: Our team has identified the issue and is actively investigating.
Posted Jul 21, 2026 - 21:02 UTC
This incident affected: Application.