Advanced Visual Reporting - Delay in Reporting Data

Incident Report for JazzHR

Resolved

Systems have caught back up. All reporting data should now be up to date.
Posted Mar 04, 2026 - 13:41 UTC

Monitoring

We are aware that reporting data may be out of date for several users. We have identified and addressed the issue causing the delay. We are actively monitoring the data as it catches back up. Delays may continue up to 24 hours from now, but customers should have all of their current and accurate data up to February 25th.
Posted Mar 03, 2026 - 20:02 UTC
This incident affected: Application.