JazzHR Email Send Issue

Incident Report for JazzHR

Resolved

This incident has been resolved
Posted Mar 03, 2025 - 11:27 UTC

Investigating

We’re investigating an issue impacting email in JazzHR, including candidate import via email and email forwarding
Posted Feb 28, 2025 - 19:07 UTC
This incident affected: Application.