Delayed Email Delivery
Incident Report for JazzHR
Resolved
We have identified the root cause and the issue is resolved. Emails originating from JazzHR are no longer delayed.
Posted Nov 20, 2024 - 15:20 UTC
Investigating
Emails delivered from JazzHR are currently delayed. We are investigating into the issue & will respond with updates as we progress into figuring out the root cause.
Posted Nov 20, 2024 - 14:55 UTC
This incident affected: Application.