JazzHR - Errors accessing application

Incident Report for JazzHR

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 01:39 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2025 - 19:55 UTC

Investigating

We are again experiencing some issues resulting in slow loading pages or errors within the JazzHR application. We are actively investigating
Posted Sep 24, 2025 - 18:57 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 24, 2025 - 16:04 UTC

Identified

JazzHR is experiencing some issues and users may receive an error when accessing the application. Our Engineers are actively working on a resolution
Posted Sep 24, 2025 - 15:53 UTC
This incident affected: Application.