LinkedIn Job Distribution

Incident Report for JazzHR

Postmortem

Incident Summary
Between June 5 and June 11, 2026, JazzHR customers experienced issues where job postings were failing to syndicate to LinkedIn. The issue also caused broader delays in syncing candidate, job, and workflow data across the JazzHR platform.

Detection
The issue was identified through multiple customer support reports starting around June 5, 2026. Internal monitoring did not initially trigger alerts because a software issue masked the underlying errors, making the system appear healthy in logs. Active engineering investigation began on June 11, 2026, at 1:29 PM EDT after reports were escalated.

Root Cause
The issue was caused by a breakdown in how our systems communicate and translate data.

  • Missing Data Blueprints: Our systems use "blueprints" to understand and process the information sent between JazzHR and LinkedIn. Due to a configuration error on June 4, a set of these older blueprints was accidentally removed.
  • Processing Blockage: When the system encountered job data that required those specific missing blueprints, it didn't know how to read the information. Instead of skipping the problematic data, the system became "stuck" trying to process the same records over and over.

Resolution
Engineering teams implemented a multi-step resolution on June 11, 2026:

  • Error Exposure: The software issue masking the error was fixed, allowing engineers to see the true cause of the failure.
  • Queue Management: We deployed a fix that isolates unreadable data into a separate queue for recovery. This prevented individual data errors from blocking the rest of the system, allowing us to clear the backlog and restore normal service for all customers.
  • Service Restoration: Once the blocked records were moved, the backlog of pending job postings began processing immediately. By 10:17 PM EDT on June 11, the system was unblocked, and by the morning of June 12, the majority of the data backlog had been cleared.

Preventative Measures
To prevent a recurrence of this issue, the following actions are being taken:

  • Configuration Hardening: We are verifying and locking the storage settings for data blueprints to ensure they are never prematurely deleted again.
  • Enhanced Monitoring: New alerts have been established to detect "data lag" and "unreadable records" immediately. This ensures that if a data flow stops, engineering is notified before customers are impacted.
  • Standardized Error Handling: The queue management safety mechanism is being expanded across all JazzHR data services to ensure that a single bad record cannot stop the entire system.
Posted Jun 17, 2026 - 18:30 UTC

Resolved

This incident has been resolved.

Incident Duration: June 5 - June 12
Impact Summary: Some jobs for some customers may fail to publish correctly to LinkedIn.
Cause: LinkedIn has updated their preferred method of job data ingestion for job posting and there were some data conflicts caused by referencing the older method at the same time as the updated method.
Mitigation: Validated integration code and system behavior to insure all publishing attempts go through the updated preferred method from LinkedIn at all times.

An RCA will be provided within 7-10 business days if applicable.
Posted Jun 15, 2026 - 14:58 UTC

Monitoring

We have implemented a correction for this issue where publishing jobs from JazzHR to LinkedIn was intermittently failing. We have reviewed the examples we had and are monitoring posting error rates, we believe all jobs will not publish as expected. We will continue to monitor over the weekend.

Next update: Monday June 15.
Posted Jun 12, 2026 - 19:07 UTC

Identified

We have identified the most likely cause of the ongoing issues with Jobs not successfully posting to LinkedIn and our engineering team is working with LinkedIn to correct the issues as soon as possible.

Further updates will be provided by tomorrow or soon if more information becomes available.
Posted Jun 11, 2026 - 18:34 UTC

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 21:43 UTC

Update

We are continuing to investigate this issue, we have confirmed that most Job Publishing actions with LinkedIn are completing successfully and reviewing this with LinkedIn.

If none of your jobs are publishing to LinkedIn at all, please first visit the Account Information Page and verify your LinkedIn Company ID is correctly set there. Help Center guide at https://help.jazzhr.com/s/article/Mapping-your-LinkedIn-Company-ID
Posted Jun 10, 2026 - 18:57 UTC

Investigating

Investigating — We have identified that some JazzHR customers are experiencing issues with jobs not posting to LinkedIn through the automated job syndication integration. Jobs submitted through the integration may not be appearing on LinkedIn as expected.

Our Engineering team is actively investigating the issue in coordination with LinkedIn. We are working to confirm the full scope of jobs that are not posted as expected and reprocess any postings we can correct directly. In the meantime, it is possible to post a link to a job directly through LinkedIn as a temporary workaround.
Posted Jun 09, 2026 - 21:18 UTC
This incident affected: API.