Email Notifications Delayed or Missing for Job Approval Requests

Incident Report for JazzHR

Resolved

This incident has been resolved.

Incident Duration: 4/14;2026 @ 2:52 PM ET – 4/16/2026 @ 10:25 AM ET
Impact Summary: Users experienced delays in receiving emails for Job Approval Requests
Posted Apr 16, 2026 - 14:28 UTC

Identified

We have identified an issue affecting email sends for Job Approval requests.
Users may experience delays in receiving emails after a job is approved.

Next update: 123 pm ET or sooner.
Posted Apr 16, 2026 - 14:12 UTC
This incident affected: Application.